lab topology
deltaos -- cisco ios
deltaos
ge0: 10.11.2.2
cisco ios
g0/0: 10.11.2.10
lab configuration
current configuration
# show running-config
# DELTAOS CONFIG VERSION: 0
interface ge 0
no ip address
shutdown
interface ge 1
no ip address
shutdown
line console
line serial
line vty
no login
transport input none
end
configure the static ip on deltaos ge0
# conf t
(config)# int ge0
(config-if)# ip address 10.11.2.2 255.255.255.0
(config-if)# no shutdown
(config-if)# end
#
enable ipip tunnel on deltaos
# conf t
(config)# interface tunnel 1
(config-if)# tunnel mode ipip
(config-if)# tunnel source 10.11.2.2
(config-if)# tunnel destination 10.11.2.10
(config-if)# ip address 12.1.1.2 255.255.255.0
(config-if)# no shutdown
(config-if)# end
#
configure ipip tunnel on cisco ios
# conf t
(config)# int g0/0
(config-if)# ip address 10.11.2.10 255.255.255.0
(config-if)# no shutdown
(config-if)# end
# conf t
(config)# interface tunnel 1
(config-if)# tunnel mode ipip
(config-if)# tunnel source 10.11.2.10
(config-if)# tunnel destination 10.11.2.2
(config-if)# ip address 12.1.1.1 255.255.255.0
(config-if)# no shutdown
(config-if)# end
#
test ipip tunnel on deltaos
# ping 12.1.1.1
type ctrl-c to abort.
sending 5, 100-byte icmp echos to 12.1.1.1, timeout is 3s, interval is 1ms:
!!!!!
success rate is 100 percent (5/5), round-trip min/avg/max = 0.583/0.866/1.164 ms