lab topology
r2
/ \
/ \
r1 --- r3
r1 is deltaos, r2, r3 are cisco ios.
r1
ge0: 12.1.1.1/30
ge1: 13.1.1.1/30
lo0: 1.1.1.1/32
r2
g0/0: 12.1.1.2/30
g0/1: 23.1.1.1/30
lo0: 2.2.2.2/32
r3
g0/0: 13.1.1.2/30
g0/1: 23.1.1.2/30
lo0: 3.3.3.3/32
lab configuration
r1
interface ge 0
ip address 12.1.1.1 255.255.255.252
no shutdown
interface ge 1
ip address 13.1.1.1 255.255.255.252
no shutdown
interface loopback 0
ip address 1.1.1.1 255.255.255.255
no shutdown
router bgp 65100
address-family ipv4 unicast
network 1.1.1.1 mask 255.255.255.255
neighbor 12.1.1.2
remote-as 65200
address-family ipv4 unicast
neighbor 13.1.1.2
remote-as 65300
address-family ipv4 unicast
r2
interface loopback 0
ip address 2.2.2.2 255.255.255.255
no shutdown
interface GigabitEthernet0/0
ip address 12.1.1.2 255.255.255.252
no shutdown
interface GigabitEthernet0/1
ip address 23.1.1.1 255.255.255.252
no shutdown
router bgp 65200
neighbor 12.1.1.1 remote-as 65100
neighbor 23.1.1.2 remote-as 65300
address-family ipv4
network 2.2.2.2 mask 255.255.255.255
neighbor 12.1.1.1 activate
neighbor 23.1.1.2 activate
exit-address-family
r3
interface loopback 0
ip address 3.3.3.3 255.255.255.255
no shutdown
interface GigabitEthernet0/0
ip address 13.1.1.2 255.255.255.252
no shutdown
interface GigabitEthernet0/1
ip address 23.1.1.2 255.255.255.252
no shutdown
router bgp 65300
bgp log-neighbor-changes
neighbor 13.1.1.1 remote-as 65100
neighbor 23.1.1.1 remote-as 65200
address-family ipv4
network 3.3.3.3 mask 255.255.255.255
neighbor 13.1.1.1 activate
neighbor 23.1.1.1 activate
exit-address-family
check result
r1
r1# show ip bgp
Status codes: * valid, > best, r RIB-failure
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 0.0.0.0 0 32768 i
*> 2.2.2.2/32 12.1.1.2 0 0 0 65200 i
* 13.1.1.2 0 0 0 65300 65200 i
*> 3.3.3.3/32 13.1.1.2 0 0 0 65300 i
* 12.1.1.2 0 0 0 65200 65300 i
r2
r2#show ip bgp
BGP table version is 4, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
t secondary path,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
* 1.1.1.1/32 23.1.1.2 0 65300 65100 i
*> 12.1.1.1 0 65100 i
*> 2.2.2.2/32 0.0.0.0 0 32768 i
* 3.3.3.3/32 12.1.1.1 0 65100 65300 i
*> 23.1.1.2 0 0 65300 i
r3
r3#show ip bgp
BGP table version is 4, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
t secondary path,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
* 1.1.1.1/32 23.1.1.1 0 65200 65100 i
*> 13.1.1.1 0 65100 i
* 2.2.2.2/32 13.1.1.1 0 65100 65200 i
*> 23.1.1.1 0 0 65200 i
*> 3.3.3.3/32 0.0.0.0 0 32768 i